-->

ShetiPhianCore Library Mod [1.19, 1.18.2] (For Minecraft ShetiPhian’s Mods)

ShetiPhianCore Library Mod [1.19, 1.18.2] (For Minecraft ShetiPhian’s Mods)

 All ShetiPhian modifications require the Minecraft ShetiPhianCore library mod for 1.19, 1.18.2, 1.18.1, 1.18, 1.17.1, 1.17, 1.16.5, 1.15.2 (Forge Loader). It is required to have it installed else ShetiPhian's modifications would crash.

ShetiPhianCore Library Mod [1.19, 1.18.2] (For Minecraft ShetiPhian’s Mods)
ShetiPhianCore Library Mod [1.19, 1.18.2] (For Minecraft ShetiPhian’s Mods)

Mods that use this core:

  • EnderTanks
  • Miscellaneums
  • Illumine
  • MultiBeds
  • PixelPowers 2
  • MultiStorage
  • Terraqueous
  • Platforms


Download ShetiPhianCore Library Mod for Minecraft 1.19

Download ShetiPhianCore Library Mod for Minecraft 1.18.2

Download ShetiPhianCore Library Mod for Minecraft 1.18.1

Download ShetiPhianCore Library Mod for Minecraft 1.18

Download ShetiPhianCore Library Mod for Minecraft 1.17.1

Download ShetiPhianCore Library Mod for Minecraft 1.17

Download ShetiPhianCore Library Mod for Minecraft 1.16.5

Download ShetiPhianCore Library Mod for Minecraft 1.15.2

See Also

Comments